Follow Us On Follow us on Facebook Follow us on Twitter Watch us on YouTube Instagram
Register
Rock Spyder 4x4
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: JL V41 Issue

  1. #11
    Active Member Biggy's Avatar
    Join Date
    Apr 2013
    Location
    Pontypool
    Posts
    601
    Mentioned
    27 Post(s)
    With 65000 km you definitely could have some other things going like unit bearings, ball joints etc. I would get the tech in the vehicle with you for a test ride.

    Sent from my SM-N950W using Tapatalk
    09 JKU Rubicon -- RK 3.5 -- 37" Toyo MT


    OF4WD # 6644

  2. #12
    Member
    Join Date
    Feb 2017
    Location
    Guelph...makes sense
    Posts
    95
    Mentioned
    2 Post(s)
    The thing is, before they installed the dampener, the vehicle drove just fine.
    Now it oscillates when I encounter a bump in the road at speed and the newly installed dampener appears to be installed incorrectly. I donít think itís something else but Iíll let the dealer look at it and will insist they come with me for a test drive. Thanks.


    Sent from my iPhone using Tapatalk

  3. #13
    JeepCentral Sponsor - Just Jeeps adrian@justjeeps's Avatar
    Join Date
    Nov 2013
    Location
    Toronto/Barrie
    Posts
    1,824
    Mentioned
    219 Post(s)
    Quote Originally Posted by DFT View Post
    You mean to say the jl has zero degrees caster? That is odd

    Sent from my ASUS_X018D using Tapatalk
    Almost, most of them are only around 2*

  4. #14
    Member
    Join Date
    Feb 2017
    Location
    Guelph...makes sense
    Posts
    95
    Mentioned
    2 Post(s)
    The dealer fixed it, with no issues. The dealer installed a new dampener and everything seems to operate properly now.
    The other dampener was on incorrectly.
    .


    Sent from my iPhone using Tapatalk

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •